ranger en pairs et impairs les éléments d'un tableau

Aller en bas

ranger en pairs et impairs les éléments d'un tableau

Message  Admin le Ven 1 Avr - 21:59

ÉNONCÉ:
On veut écrire un programme permettant de remplir deux tableaux T1 et T2 de tailles maximales n(n<100) par des entiers positifs, puis de ranger respectivement les éléments pairs de T1 puis ceux de T2 dans un tableau Tpair. Ensuite calculer la moyenne arithmétique des éléments de Tpair et affiche tous les éléments Tpair strictement supérieurs à sa moyenne arithmétique.

ALGORITHMES

1. ALGORITHME PROCEDURE LECTURE

0)DEF PROC LECTURE (var n :entier, var T1,T2:TAB)
1) répéter
écrire(“saisir n ”)
lire(n)
jusqu’à (n>0) et (n <100)
écrire(« chargement de T1 »)
pour i de 1 a n répéter
ecrire(« introduire l’élément n° »,i) ;
lire(T1[i])
jusqu’ à (T1[i]>0)
fin pour
ecrire(« chargement de T2 »)
pour i de 1 a n répéter
ecrire(« introduire l’élément n° »,i) ;
lire(T2[i])
jusqu’ à (T2[i]>0)
fin pour
2)fin lecture

2. ALGORITHME PROCEDURE PAIRE

0)DEF PROC paire (var Tpair:TAB1, VAR cp:entier)
1)cp<-1
pour i de 1 de a cp répéter
si T1[i] mod 2=0 alors
T[cp]<-T1[i]
Finsi
si T2[i] mod 2=0 alors
T[cp]<-T1[i] Finsi
Fin Pour
Cp<-cp-1
2)Fin paire

3. Algorithme fonction arith

0) DEF FN Arith (Tp :tab1,cp :entier) :reel
1)S<-0
pou I de 1 a cp repeter
S<-s+tp[i]
Fin Pour
Arith<-S/cp
2)Fin Arith

4. Algorithme procédure affichage

0)DEF PROC AFFICHaGE
1)Pour I de 1 a n répéter
Si Tpair[i]> moy
Alors
Ecrire(tpair[i])
finsi
2)Fin affichage

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

correction d'erreurs

Message  Admin le Ven 1 Avr - 22:01

essayez de corriger les erreurs dans ce programme (procédure paire), puis essayez de donner une meilleure solution

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

traduction pascal

Message  Admin le Ven 1 Avr - 22:02

essayez maintenant d'écrire un programme pascal correspondant à ce problème

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum