afficher un commentaire suivant l'age

Aller en bas

afficher un commentaire suivant l'age

Message  Admin le Ven 1 Avr - 23:24

ÉNONCÉ

Ecrire un algorithme AGE permettant d’afficher un commentaire en fonction l’age (A), d’une personne donné :

• Age de 0 à 15 --> Vous êtes bien jeune
• Age de 16 à 30 --> Félicitations
• Age de 31 à 50 --> Ca va encore
• Age de 51 à 130 --> C’est le tournant final
• Age de 131 et plus --> Menteur ! !

ANALYSE

Nom :Age
Résultat= Ecrire (mess)
Mess=[]
Si A Dans [0 .. 15] Alors Mess<--" Vous êtes bien jeune"
Sinon Si A dans [16 ..30] Alors Mess<-- "Félicitations"
Sinon Si A dans [31..50] Alors
Mess<--" Ca va encore"
Sinon Si A dans [51..130] Alors
Mess<--" C’est le tournant final"
Sinon Si (A>=131) ou (A<0 ) Alors
Mess<--"Menteur ! !"
Finsi
FinSi
FinSi
FinSi
FinSi
A = Donnée("Saisir votre Age")
Fin Age

ALGORITHME

0) Debut Age
1) Ecrire ("saisir votre age") Lire(a)
2) Si A Dans [0 .. 15] Alors Mess<--" Vous êtes bien jeune"
Sinon Si A dans [16 ..30] Alors Mess<-- "Félicitations"
Sinon Si A dans [31..50] Alors
Mess<--" Ca va encore"
Sinon Si A dans [51..130] Alors
Mess<--" C’est le tournant final"
Sinon Si A>=131 ou A<0 Alors
Mess<--"Menteur ! !"
Finsi
FinSi
FinSi
FinSi
FinSi
3) Ecrire(Mess)
4)Fin Age

PASCAL

Program Age ;
Uses Wincrt;
Var a: Integer;
Mess : String;
Begin
Write ('saisir votre age');
Read(a);
If A in [0 ..15] Then
Mess:=' Vous êtes bien jeune'
Else If A In [16 ..30] Then
Mess:='Félicitations'
Else If A In [31..50] Then
Mess:=' Ca va encore'
Else If A In [51..130] Then
Mess:=' C'’est le tournant final'
Else If (A>=131) Or (A<0) Then
Mess:='Menteur ! !';
Write(Mess);
End.


Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

utiliser selon..faire

Message  Admin le Ven 1 Avr - 23:29

réécrire ce programme en utilisant la structure selon ..faire

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum