entier cubique

Aller en bas

entier cubique

Message  Admin le Ven 1 Avr - 23:44

ÉNONCÉ
Un entier naturel de trois chiffres est dit cubique s’il est égal à la somme des cubes de ses trois chiffres.
Exemple : 153 est cubique car 153=13+53+33
Ecrire une analyse, algorithme et une traduction pascal d’un programme intitulé « Cubique » qui permet de lire un entier et vérifier s’il est cubique.


ANALYSE
Nom : Cubique
Résultat= Cub
Cub=[] Si S=N Alors
Ecrire("le nombre :",N,"Cubique")
Sinon
Ecrire("le nombre :",N,"n'est pasCubique")
FinSi
Centaine<-- N div 100
Dizaine <--(N Mod 100) Div 10
Un<-- N Mod 10
S<--Carre(centaine)*Centaine+carre(dizaine)*dizaine+carre(un)*un
N = Donnée("saisir votre entier")

ALGORITHME
0)Debut Cubique
1) Ecrire("saisir votre Entier")Lire (N)
2) Centaine<-- N div 100
3) Dizaine <--(N Mod 100) Div 10
4) Un<-- N Mod 10
5) S<--Carre(centaine)*Centaine+carre(dizaine)*dizaine+carre(un)*un
6) Si S=N Alors
Ecrire("le nombre :",N,"Cubique")
Sinon
Ecrire("le nombre :",N,"n'est pasCubique")
FinSi
7) Fin Cubique

PASCAL
Program Cubique;
uses wincrt;
var Centaine,Dizaine,un, s,n: integer;
begin
Write('saisir votre Entier');
read (N);
Centaine:= N div 100;
Dizaine :=(N Mod 100) Div 10;
Un:= N Mod 10;
s:=sqr(centaine)*Centaine+sqr(dizaine)*dizaine+sqr(un)*un;
if S=N then
Write('le nombre :',N,'Cubique')
Else
Write('le nombre :',N,'n''est pasCubique');
end.

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum