divisibilité par le chiffre de dizaines

Aller en bas

divisibilité par le chiffre de dizaines

Message  Admin le Sam 2 Avr - 11:11

ÉNONCÉ
24 est un entier divisible par son chiffre des dizaines (2).
Ecrire une analyse, un algorithme et la traduction en pascal d’un programme intitulé « Dizaine » qui permet de lire un entier (N) et vérifier s’il est divisible par son chiffre des dizaines.
Remarque : 10<=N<100

ANALYSE
Nom : Dizaine
Résultat= Sol
Sol=[]
Si N Mod D=0 Alors
Ecrire(N, "est divisible par ",D)
Sinon Ecrire(N, "n'est pas divisible par ",D)
Finsi
D<-- N Div 10
N = Donnée ("saisir N")
Fin Dizaine

ALGORITHME
0) Debut Dizaine
1) Ecrire ("saisir N") Lire(N)
3) D<-- N Div 10
2)Si N Mod D=0 Alors
Ecrire(N, "est divisible par ",D)
Sinon
Ecrire(N, "n'est pas divisible par ",D)
Finsi
Fin Dizaine

PASCAL
Program Dizaine;
uses Wincrt;
Var N,D : Integer;
begin
Write ('saisir N');
Read(N);
D:=N div 10;
If N Mod D=0 Then
Write(N, 'est divisible par ',D)
Else
Write(N, 'n''est pas divisible par ',D);
End.


Dernière édition par Admin le Sam 2 Avr - 11:30, édité 1 fois

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

contrôle de saisie

Message  Admin le Sam 2 Avr - 11:12

modifier ce programme pour qu'il puisse contrôler la saisie de l'entier (>=10 et <100)

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum