équation de deuxième degré

Aller en bas

équation de deuxième degré

Message  Admin le Sam 2 Avr - 11:30

ÉNONCÉ
Ecrire une analyse, un algorithme et la traduction en pascal d’un programme intitulé « 2eme_degré »qui permet la résolution d’une équation du deuxième degré à une inconnue X, de forme AX2 + BX+C= 0.
On suppose que a, b ,c et x sont des réels.
NB : le programme doit traiter tous les cas possibles.

ANALYSE
Nom : 2ème-Degre
Résultat= Sol
Sol=[]
Si a<>0 Alors
Delta<--Carre(b)- 4*a*c
Si delta<0 alors
Ecrire("a solution est l'enseble vide'')
Sinon
Si delta= 0 Alors
Ecrire("X1=X2 =", -b/2*a)
Sinon
Ecrire("X1=",(-b- racine-carre(Delta))/2*a, "X2=",(-b+ racine-carre(Delta))/2*a)
FinSi
FinSi
SinNon
Si b<>0 Alors
Ecrire("La solution de l'équation est :",-c/b)
Sinon si C=0 Alors
Ecrire("La solution de l'équation est : IR")
Sinon
Ecrire("La solution de l'équation est impossible")
Finsi
Finsi
FinSi

ALGORITHME
0) Debut 2ème_degre
1) Ecrire ("saisir a") Lire(a)
2) Ecrire("saisir b") Lire(b)
3) Ecrire("saisir c") Lire(c)
4) Si a<>0 Alors
Delta<--Carre(b)- 4*a*c
Si delta<0 alors
Ecrire("a solution est l'enseble vide'')
Sinon
Si delta= 0 Alors
Ecrire("X1=X2 =", -b/2*a)
Sinon
Ecrire("X1=",(-b- racine-carre(Delta))/2*a, "X2=",(-b+ racine-carre(Delta))/2*a)
FinSi
FinSi
SinNon
Si b<>0 Alors
Ecrire("La solution de l'équation est :",-c/b)
Sinon si C=0 Alors
Ecrire("La solution de l'équation est : IR")
Sinon
Ecrire("La solution de l'équation est impossible")
Finsi
Finsi
FinSi
5) Fin 2ème-Degre

PASCAL

Program deuxieme_degre;
Uses Wincrt;
Var a,b,c,delta :real;
begin
Write('saisir a');
Read(a);
Write('saisir b');
Read(b);
Write('saisir c');
Read(c);
If a<>0 Then
Begin
Delta:=Sqr(b)- 4*a*c;
if delta<0 Then
Write('la solution est l''enseble vide')
else
if delta= 0 Then
Write('X1=X2 =', -b/2*a:8:3)
else
Write('X1=',(-b- Sqrt(Delta))/2*a:8:3, ' X2=',(-b+ Sqrt(Delta))/2*a:8:3);
end
Else
If b<>0 Then
Write ('La solution de l''équation est :',-c/b:8:3)
Else If c=0 Then
Write('La solution de l''équation IR')
Else
Write('La solution de l''équation est impossible');

End.

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum