calcul des impôts

Aller en bas

calcul des impôts

Message  Admin le Sam 2 Avr - 11:52

ÉNONCÉ
On admet que le calcul simplifié d’impôt annuel sur les revenus se fait sur la base suivante :
Tranche (en dinars) Taux

[0,1500] -----> 0%
]1500,5000] -----> 15%
]5000, 10000] -----> 20%
]10000 et plus -----> 30%
Exemple : si revenu vaut 6520 dinars, on décompose ce revenu en tranches et on calcule l’impôt comme suit :
• Les 1 500 D --> 1 500* 0% soit 0 D
• Les 3 500 D --> 3 500* 15% soit 525 D
• Les 1 520 D --> 1 520* 20% soit 304 D
Impôt à payer :0+525+304= 829 D
Ecrire une analyse, un algorithme et la traduction en pascal d’un programme intitulé « Impôt » qui permet la saisie du revenu annuel et calcule l’impôt conséquent.

ANALYSE
Nom : impot
Résultat= Ecrire(''L'impôt à payer est:'',MTimp)
(s1,s2,s3)=[ s1<--0,s2<--0,s3<--0]
Si MT>10000 Alors
S3<-- (MT-10000)*0.3
S2<--5000*0.2
S1<--3500*0.15
SiNon
Si MT>5000 Alors
S3<-- 0
S2<-- (MT-5000)*0.2
S1<--3500*0.15
SiNon
Si MT>1500 Alors
S3<-- 0
S2<-- 0
S2<-- (MT-1500)*0.15
FinSi
FinSi
FinSi
MTimp<--s1+s2+s3
MT= Donnée ("Saisir Votre Montant")
Fin Impot

ALGORITHME
0) Debut Impot
1) Ecrire ("Saisir Votre Montant ") Lire(MT)
2) s1<--0
s2<--0
s3<--0
Si MT>10000 Alors
S3<-- (MT-1000)*0.3
S2<--5000*0.2
S1<--3500*0.15
SiNon
Si MT>5000 Alors
S3<-- 0
S2<-- (MT-5000)*0.2
S1<--3500*0.15
SiNon
Si MT>1500 Alors
S3<-- 0
S2<-- 0
S1<-- (MT-1500)*0.15
FinSi
FinSi
FinSi
MTimp<--s1+s2+s3
Ecrire(''L'impôt à payer est:'',MTimp)
Fin Impot

PASCAL

program Impot;
uses wincrt;
var s1,s2,s3,Mt,Mtimp :real;
begin
Write ('Saisir Votre Montant');
read(MT);
s1:=0;
s2:=0;
s3:=0;
if MT>10000 Then
begin
S3:=(MT-10000)*0.3;
S2:=5000*0.2;
S1:=3500*0.15;
end
else
if MT>5000 Then
begin
S3:= 0;
S2:= (MT-5000)*0.2;
S1:=3500*0.15;
end
else
if MT>1500 Then
begin
S3:= 0;
S2:= 0;
S1:=(MT-1500)*0.15;
end;
MTimp:=s1+s2+s3;
Write('L''impôt à payer est:',MTimp:8:3)
end.


Dernière édition par Admin le Sam 2 Avr - 11:56, édité 1 fois

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum