Existence d'un mot dans une chaîne

Aller en bas

Existence d'un mot dans une chaîne

Message  Admin le Ven 8 Avr - 18:57

ÉNONCÉ
Ecrire une analyse ,un algorithme et un programme intitulé MOT permettant de saisir un mot et une phrase différents de la chaîne vide ,de les convertir en majuscules et d’afficher si le mot existe ou non dans la phrase s’il existe il doit afficher le nombre de fois qu’il existe.
NB:
• La fonction pos(m,p) nous permet de savoir si m existe dans p. si elle retourne la valeur 0 l'ordinateur doit afficher « n'existe pas » sinon il faut chercher le nombre de fois que m existe dans p.
• à Chaque fois qu'on trouve m dans p (pos(m,p)<>0) on ajoute 1 au nombre d'apparitions
N<--N+l et on efface le mot de la phrase pour chercher l'occurrence suivante de M.

ANALYSE
Nom=Mot
Résultat : existence
Existence =[t<--pos(M,P)]
Si t=0 alors écrire ("le mot n’existe pas dans la phrase")
sinon
n=[ N<-- 0, L<-- long(m)]
Répéter
N<--n+1
Efface (p,t,1)
T<-- pos (M,P)
Jusqu'à t=0
Ecrire ("m, "existe",n, "fois")
finsi
(m, p)=[ ]
Répéter
M= donnée (" entrer un mot")
P= donnée (" entrer une phrase")
Jusqu'à (m<> ") et (p<> ")
M= [ ] Pour i de 1 à long (m) répéter
M[ i ]<--majus (m[ i])
Fin pour
P= [ ] Pour i de 1 à long (p) répéter
P[ i ]<--majus (p[ i])
Fin pour
Fin Mot

ALGORITHME
0) début Mot
1) (m, p)= [ ]
répéter
écrire ("entrer un mot") lire(m)
écrire ("entrer une phrase") lire ( p)
Jusqu'à (m<> "") et ( p<> "")
2) Pour i de 1 à long (m) répéter
m[ i ]<-- maius(rn[i])
finpour
3) Pour i de 1 à long(p) répéter
p [ i]<-- majus(p[i])
finpour
4) t<-- pos(M, P)
Si t=0 alors écrire ("le mot n'existe pas dans la phrase")
sinon
n= [N<-- 0, L<--long(m)]
Répéter
N<-- n+l
Efface (p, t, 1)
T<-- pos (M, P)
Jusqu'à t=0
Ecrire (m," existe ",n," fois")
finsi
Fin Mot

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

traduction pascal

Message  Admin le Ven 8 Avr - 18:59

écrire le programme pascal correspondant à ce problème

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum