nombre de consonnes et nombre de voyelles

Aller en bas

nombre de consonnes et nombre de voyelles

Message  Admin le Ven 8 Avr - 19:01

ÉNONCÉ
Ecrire une analyse ,un algorithme et un programme intitulé COMPTER permettant de saisir une phrase différente de la chaîne vide et de compter le nombre de voyelles et le nombre de consonnes qui y existent

ANALYSE
Nom=COMPTER
Résultat = écrire("le nombre de voyelles= ",V, "le nombre consonnes=",C)
(V,C)=[ v ← 0, c ← 0]
pour i de 1 à long(p) répéter c
si majus(p[i]) dans["T","U","O","Y","E","A"] alors v ←v+l
sinon si majus (p[i] dans ["A".. "Z"] alors c←c+l
fmsi
finpour
P= [ ]répéter
p= donnée ("entrer une phrase")
jusqu'à long (p) <> 0
Fin Compter

ALGORITHME
0)debut compter
1)repeer
ecrire("entrer une phrase ")
lire(P)
jusqu'à long(p)<>0
2)V←0
C←0
Pour i de 1 à long(p) repeter
Si majus (p[i]) dans ["T","U","O","Y","E","A"] alors v ←v+l
sinon si majus (p[i] dans ["A".. "Z"] alors c←c+l
fmsi
finpour
3)écrire("le nombre de voyelles= ",V, "le nombre consonnes=",C)
4)Fin compter

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum