palindrome

Aller en bas

palindrome

Message  Admin le Ven 8 Avr - 19:11

ÉNONCÉ
Ecrire une analyse ,un algorithme et un programme intitulé PALINDROME permettant de lire une chaîne non vide, et d’indiquer si elle est palindrome.(une chaîne palindrome se lit de gauche a droite et de droite a gauche)
EXP : LAVAL est palindrome

ANALYSE
Nom=Palindrome
Résultat =écrire(mess)
Mess= [ ]Si P=m alors mess← "palindrome"
Sinon mess ← "non palindrome"
M=[m← ""] pour i de long(p) à 1 répéter
m← m+ p[i]
Finpour
P=[ ]répéter
donnée("entrer un mot")
jusqu'à p <> ""
Fin Palindrome

ALGORITHME
0) début palindrome
1) répéter
donnée ("entrer un mot")
jusqu'à p <>""
2) m← ""
Pour i de long (p) à 1 répéter
m←m + p[i]
Finpour
3) Si p=m alors mess←"palindrome"
Sinon mess ← "non palindrome"
4) écrire (mess)
5) Fin palindrome







Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum