parité d'un tableau

Aller en bas

parité d'un tableau

Message  Admin le Sam 16 Avr - 21:10

ÉNONCÉ:

Soit T un tableau de N entiers non nuls avec 2 < N <= 30, T est dit pair s’il vérifie la propriété suivante : "tous les éléments de T sont pairs".
1) Ecrire une analyse du programme TPAIR permettant d’afficher:
• Pair : si la propriété est vérifiée
• Non pair : si la propriété n’est pas vérifiée (au moins un élément de T n’est pas pair)
2) En déduire l’algorithme

Exemple:
1) On donne N=5, et T suivant : 2 8 10 16 -18, dans ce cas T est pair
2) On donne N=5, et T suivant : 2 5 10 16 -18, dans ce cas T est non pair

ANALYSE:
Nom= TPAIR

Résultat= écrire(Mess)
Mess= [ ] Si b= vrai alors mess <-- ”Pair” Sinon mess <--”Non pair”
Finsi
B,I=[ B <-- vrai, I <--1]
Tant que (i<=N) et (b=vrai) faire
Si t[i] mod 2 <> 0 alors b <--faux
Sinon i <-- i+1
Finsi
Fin tant que
N= [ ] Répéter
N= donnée (”entrer un nombre entre 3 et 30”)
Jusqu’à (N >=3) et (N <= 30)
T=[ ] pour i de 1 à N répéter
Répéter
T[i]= donnée (”entrer l’élément n° ”,i,” non nul ”)
Jusqu’à T[i] <> 0
Fin pour
Fin Tpair

ALGORITHME:
0) début Tpair
1) Répéter
écrire (”entrer un nombre entre 3 et 30”)
lire(N)
Jusqu’à (N >=3) et (N <= 30)
2) pour i de 1 à N répéter
Répéter
T[i]= donnée (”entrer l’élément n° ”,i,” non nul ”)
Jusqu’à T[i] <> 0
Fin pour
3) B <--vrai
I <--1
Tant que (i<=N) et (b=vrai) faire
Si t[i] mod 2 <> 0 alors b<-- faux
Sinon i <-- i+1
Finsi
Fin tant que

4) Si b= vrai alors mess <--”Pair”
Sinon mess <-- ”Non pair”
Finsi
5) écrire(Mess)
6) Fin Tpair


Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum