jeu de mots: énoncé et analyse

Aller en bas

jeu de mots: énoncé et analyse

Message  Admin le Dim 13 Mar - 16:55

ÉNONCÉ
Afin d’enrichir le vocabulaire des ses élèves en français, un enseignant souhaite mettre au point un programme didactique sous forme d’un jeu se déroule entre deux élèves. On admet que les mots proposés sont formés uniquement par des lettres majuscules.
Le jeu se termine de la manière suivante :
- le premier élève saisit un mot
- le deuxième doit proposer un mot commençant par la dernière lettre du mot précédent proposé par le premier élève
- le premier élève en fera de même et ainsi de suite
Le jeu se termine si :
- l’un des joueurs se trompe (propose un mot qui ne commence pas par la dernière lettre du mot précédent)
- l’un des joueurs propose un mot déjà cité lors du jeu
- le nombre de mots cités par les deux joueurs dépasse 100
Exemple d’une partie du jeu:
Joueur1 : JARDIN
Joueur2 : NATAL
Joueur1 : LOUP
Joueur 2 : URNE
L’élève n°1 est vainqueur

analyse du programme principal :
Résultat = PROC affichage (j)
Ecrire (˝*********jouons avec les mots***********˝)
j←0
(ch1,t,j)=PROC saisie (ch1, t, j)
(ch1,t,j)=PROC saisie (ch2, t, j)
repéter
l←long(ch1);
c←ch1[l];
ok← FN test(c,ch2)
si ok
alors
ch1←ch2
PROC saisie(ch2,t,j) fin si
jusqu’à (ok=false) ou (j=100);
FIN jouons

analyse du module saisi
Résultat = (mot1,t1,j1)
j1←j1+1
if j1 mod 2 =0
alors écrire (˝ joueur 2˝)
sinon écrire (˝joueur 1˝)
repeter
ecrire (˝saisir une chaine˝)
lire(mot1)
lettre←true
i←0
repeter
i←i+1
if non( mot1[i] dans ['A'..'Z','a'..'z']) alors lettre←false
jusqu’à (lettre=false) or (i=long(mot1))
jusqu’à lettre

t1[j1] ←mot1
Fin Saisie

analyse module test
Resultat= test
si c1=ch[1]
alors
test←true
pour ide 1 à j-1 répéter
si ch=t[i] alors test← false Finsi

sinon
test←false
Finsi
Fin test

analyse module affichage
Resultat = affi_Res
Affi_Res=[]
si j1=100 alors écrire (˝exaequo˝)
alors
si j1 mod 2 =0
alors écrire (˝'l''eleve N°1 est vainqueur˝')
sinon écrire (˝'l''eleve N°2 est vainqueur˝);
Fin si
Fin affichage


Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum