commission

Aller en bas

commission

Message  Admin le Sam 2 Avr - 12:09

ÉNONCÉ

La commission d’un employer sur les ventes totales est :
• Si Ventes < 50 dinars. Il n’y a pas de commission.
• Si 50 ≤ Ventes ≤ 500 dinars. La commission est égale à 10% des ventes.
• Si ventes > 500 dinars. La commission est de 50 dinars plus 8% des ventes au dessus de 500 dinars.
Ecrire une analyse, un algorithme et le programme pascal permettant de saisir la somme totale des ventes, calcule et affiche le montant de la commission.

ANALYSE
Nom : Commission
Résultat= Ecrire(''la commission est :",Com)
(Com)=[]
Si vente>500 Alors
Com<--50+((vente-500)*0.08)
SiNon
Si vente>50 Alors
Com<--vente*0.10
SiNon
Com<--0
FinSi
FinSi
vente:Donnée(" Saisir le montant des ventes:")
Fin Commission

ALGORITHME
0) Debut Commission
1) Ecrire ("Saisir le montant des ventes ") Lire(Vente)
2) Si vente>500 Alors
Com<--50+((vente-500)*0.08)
SiNon
Si vente>50 Alors
Com<--vente*0.10
SiNon
Com<--0
FinSi
FinSi
3) Ecrire(''la commission est :",Com)
4) Fin Commission

PASCAL
program Commission;
uses wincrt;
var Vente,com:real;
begin
Write('Saisir le montant des ventes ');
read(vente);
if vente>500 Then
com:=50+(vente-500)*0.08
else
if vente>50 Then
com:=vente*0.10
else
com:=0;
Write('La commission est:',com:8:3);
end.

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum