recherche dans un tableau

Aller en bas

recherche dans un tableau

Message  Admin le Ven 8 Avr - 18:47

ENONCE
Ecrire une analyse ,un algorithme et un programme intitulé CHERCHER permettant de saisir une valeur A et N éléments d’un tableau V et d’afficher l’indice de la casse de V ou se trouve la valeur A si elle existe dans le tableau, sinon il doit afficher « n’existe pas »

ANALYSE
Nom=CHERCHER
Résultat = existence
existence=[ ] Si b= Vrai Alors écrire(A, " existe dans la case n° " ,i)
Sinon écrire (A, " n'existe pas")
i= [b= faux, i ←1] tant que (b←faux) ou (i<=N) faire
Si V[i]=A alors b←vrai
Sinon i ← i+l
Finsi
Fin tant que
A= donnée ("entrer un caractère")
V= [ ] pour i de 1 à N répéter
V[i]=donnée ("entrer V[",I, "]")
Fin pour
N= [ ] Répéter
N = donnée ("entrer un nombre entre 2 et 50 ")
Jusqu'à N dans [2..50]
Fin chercher

ALGORITHME

0) Début chercher
1) Répéter
écrire ("entrer un nombre entre 2 et 50")
Lire (N)
Jusqu'à N dans [2..50]
2) pour i de 1 à N répéter
écrire ("entrer V[",i, "]")
Lire (V[i])
Fin pour
3) écrire("entrer un caractère")
lire(A)
4) b= faux
i←1
Tant que (b=faux) ou (i<=N) faire
Si V[i]=A alors b←vrai.
Sinon i←i+l
Finsi
I=i+l
Fin tant que
5) Si b= Vrai Alors écrire (A, " existe dans la case n° " ,i)
Sinon écrire (A, "n’existe pas ")

6) Fin chercher

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

explication

Message  Admin le Ven 8 Avr - 18:50

• La valeur A peut se trouver dans plus d’une case dans V
Exp.
1 2 3 4 5 6
A 1 F * F 4

Si A= ‘‘F ’’alors elle se trouve dans les cases n° 3 et 5 ; le quel des indices on va afficher ?
On va afficher le premier indice, c'est pourquoi si la valeur de A est trouvée il n'y a plus besoin continuer à chercher.
La variable booléenne b va assurer cette action. Puisque b sera initialisée à Faux et modifiée à vrai lorsque A est trouvée.
La taille de V n'est pas exactement précisé dans l'énoncé, on va utiliser un tableau de 50 éléments au maximum et 2 éléments au minimum.

Admin
Admin

Messages : 137
Date d'inscription : 29/12/2010

Voir le profil de l'utilisateur http://aidescolaire.yoo7.com

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum